Autor Tema: Dudas con mi tarjeta de red wifi, no consigo hablitar las redes inalanbricas.  (Leído 4108 veces)

0 Usuarios y 1 Visitante están viendo este tema.

damic4

  • Novato
  • *
  • Mensajes: 3
  • Karma: +0/-0
    • Ver Perfil
Muy buenas compañeros, tengo problemas para conectarme via wifi, como comentaba en mi presentacion soy nuevo en este mundo, intentare expresarme lo mejor posible para intentar averiguar mi problema, en primer lugar comentaros que mi tarjeta de red es una Atheros AR5001 y antes me iba bien en ubuntu, un dia se me ocurrio instalar opensuse y tenia problemas para conectar via wifi, asi que probe desabilitando y volver a habilitar, mi sopresa fue que desde entonces no puedo habilitar mi red wifi, me sale pero no m dejaba activar la casilla, asik decidi cambiar la distro por kubuntu, pero me encontre con el mismo problema y aora con linux mint tmbien tngo el mismo problema mi pregunta seria la siguiente, puede ser por los drivers? debido a mi escasez de conocimientos en linux no se ni como se mira esto. He visto varios tutos para los driver de mi tarjeta madwifi,Ndiswrapper, etc... pero tengo miedo de crear conflictos con las librerias (en windows es lo que esambla el hardware con el S.O no? o aki son modulos? estoy hecho un lio) y eso seria enterrarme mas todavia, se me olvidaba por si sirve de algo la red por cable me va de lujo, y cuando ejecuto el comando ifconfig en la terminal me salen los datos de eth0 y lo nisiquiera aparece wlan0. Si alguien pudiese ayudarme le estaria muy agradecido.

P.D: si necesitais mas informacion me teneis que decir como conseguirla, insisto soy nuevo y no doy pie con bola. Gracias de antemano.


hanot

  • Novato
  • *
  • Mensajes: 4
  • Karma: +0/-0
    • Ver Perfil
Re: Dudas con mi tarjeta de red wifi, no consigo hablitar las redes inalanbricas.
« Respuesta #1 en: 02 de Agosto de 2011, 04:12:44 am »
Has probado a actualizar los drivers?? :)
Sigue este tutorial que es para otra cosa pero en el fondo lo que hace es actualizar y parchear.
Accedemos a http://wireless.kernel.org/en/users/Download/stable/ y nos bajamos el paquete correspondiente a la versión de nuestro Kernel. (Para saber qué versión tenemos ejecuta uname -r )
En este momento tengo instalada la 2.6.38, así que me bajaré compat-wireless-2.6.38.2-2.tar.bz2

Una vez bajado, mediante el terminal nos dirigimos al directorio en el que se encuentra el paquete y ejecutamos los siguientes pasos:
tar -jxf compat-wireless-2.6.38.2-2.tar.bz2
cd compat-wireless-2.6.38.2-2
wget http://patches.aircrack-ng.org/channel-negative-one-maxim.patch
sudo apt-get install patch
patch ./net/wireless/chan.c channel-negative-one-maxim.patch
make
sudo make install
sudo make unload
sudo reboot

Lo de parchear te lo puedes saltar .
Es un copy paste de esta pagina http://0kelvins.blogspot.com/2011/07/arreglar-el-problema-de-aricrack-ng.html

Saludos y espero que te funcione
Aprendiz de todo,maestro de nada.
@hanottt