torrezno

Autor Tema: Juegos no arrancan con Linux Mint 10 64bits  (Leído 7261 veces)

0 Usuarios y 1 Visitante están viendo este tema.

gilog73

  • Novato
  • *
  • Mensajes: 48
  • Karma: +2/-0
    • Ver Perfil
Juegos no arrancan con Linux Mint 10 64bits
« en: 05 de Mayo de 2011, 07:49:02 am »
Después de solucionar los ejecutables  .exe .Cuando consigo instalarlos el juego intenta arrancar pero no hace nada . También me  pasa con google earth y también he probado con steam y half life 2 . También he quitado compiz config y sigo igual . Tengo instalado play on linux , wine y winetricks . En el caso de flatout2 me sale la pantalla de inicar juego pero nada .  Gracias .


mint777

  • Moderador Global
  • Usuario Héroe
  • *****
  • Mensajes: 1820
  • Karma: +118/-1
  • Only 64 bits user
    • Ver Perfil
Re: Juegos no arrancan con Linux Mint 10 64bits
« Respuesta #1 en: 05 de Mayo de 2011, 07:59:37 am »
esas aplicaciones que mencionas hacen uso intensivo de aceleracion 3d, verifica que cumples con los requisitos correspondientes:
por ejemplo, para correr decentemente el flatout2, necesitas:
procesador como minimo a 1.5 ghz.
512 mb de ram libres (aparte de la ram que usa el S.O.)
tarjeta grafica o chipset con 128 mb
Fuera de la Net por causas de fuer$a mayor.....come back later.

gilog73

  • Novato
  • *
  • Mensajes: 48
  • Karma: +2/-0
    • Ver Perfil
Re: Juegos no arrancan con Linux Mint 10 64bits
« Respuesta #2 en: 05 de Mayo de 2011, 11:23:33 am »
Vale os pongo mi hardware de mi pc : asus p5K Premium + Intel Core 2 duo 8500 +Ram-  4Gb  DDr2 Corsair a 1066 + Tarjt.Gráfica : NVidia 560 Ti de Gigabyte
+ controlador privativo NVidia : NVIDIA-Linux-x86_64-270.41.06.run .
Los cumplo de sobra pero no se porque por ejemplo desde jd.sh ningún problema , pero tanto con los juegos y google earth hacen como que arrancan y se cierran , he probado de todo hasta como administrador desde el menú contextual . La verdad es que si sigo así me paso otra vez a los 32 bits .
« Última modificación: 05 de Mayo de 2011, 11:25:48 am por gilog73 »


mint777

  • Moderador Global
  • Usuario Héroe
  • *****
  • Mensajes: 1820
  • Karma: +118/-1
  • Only 64 bits user
    • Ver Perfil
Re: Juegos no arrancan con Linux Mint 10 64bits
« Respuesta #3 en: 05 de Mayo de 2011, 09:43:17 pm »
para resolver casos con wine, es necesario que nos de pistas de lo que esta pasando, abre una terminal y ejecuta el flatout2:

wine "ruta del archivo ejecutable"

por ejemplo, con este comando yo puedo abrir el Ares instalado con wine desde terminal:

wine "/home/minty777/.wine/drive_c/Archivos de programa/Ares/Ares.exe"

y el safari instalado con playonlinux (cambia la ruta):

wine "/home/minty777/.PlayOnLinux/wineprefix/Safari/drive_c/Archivos de programa/Safari/safari.exe"

en resumen, las aplicaciones con wine se instalan en:

/home/minty777/.wine/drive_c/Archivos de programa

y con playonlinux en:

/home/minty777/.PlayOnLinux/wineprefix/nombredelprograma/drive_c/Archivos de programa/

NOTA: no se te olvide entrecomillar la ruta como en el ejemplo.

Cuando hayas ejecutado flatout2 desde terminal, copia y pega lo que te aparece aqui.
Fuera de la Net por causas de fuer$a mayor.....come back later.

gilog73

  • Novato
  • *
  • Mensajes: 48
  • Karma: +2/-0
    • Ver Perfil
Re: Juegos no arrancan con Linux Mint 10 64bits
« Respuesta #4 en: 06 de Mayo de 2011, 02:20:30 am »
Este error me sale sin  poner "sudo su" es decir creo sin ser superusuario :

Failed to load binary database 'data'/Database/FlatOut2.db'¡[/color

Y poniendo sudo su :

mikkel-P5K-Premium mikkel # wine "/home/mikkel/.wine/dosdevices/c:/Archivos de programa/FlatOut 2/flatout2.exe"
fixme:system:SetProcessDPIAware stub!
fixme:dwmapi:DwmIsCompositionEnabled 0x33cfdc
fixme:file:MoveFileWithProgressW MOVEFILE_WRITE_THROUGH unimplemented
fixme:advapi:SetNamedSecurityInfoW L"C:\\windows\\system32\\gecko\\1.0.0\\wine_gecko\\components\\xpti.dat" 1 536870916 (nil) (nil) 0x1fd6ac (nil)
fixme:iphlpapi:NotifyAddrChange (Handle 0xa73e8d8, overlapped 0xa73e8e0): stub
fixme:file:MoveFileWithProgressW MOVEFILE_WRITE_THROUGH unimplemented
fixme:advapi:SetNamedSecurityInfoW L"C:\\windows\\system32\\gecko\\1.0.0\\wine_gecko\\components\\compreg.dat" 1 536870916 (nil) (nil) 0x1f11a9c (nil)
wine: configuration in '/root/.wine' has been updated.

mint777

  • Moderador Global
  • Usuario Héroe
  • *****
  • Mensajes: 1820
  • Karma: +118/-1
  • Only 64 bits user
    • Ver Perfil
Re: Juegos no arrancan con Linux Mint 10 64bits
« Respuesta #5 en: 06 de Mayo de 2011, 10:06:23 am »
Citar
Y poniendo sudo su :
no necesitas para nada ser superusuario, ya que todo lo que instales con wine o playonlinux esta en un directorio de tu usuario personal.

Leyendo tu salida, creo saber cual es el motivo de tu problema, al parecer al instalar flatout2, fallo el linkeo de directorios, para asegurarnos:

abre terminal y ejecuta estos 2 comandos seguidos uno de otro:

Código: [Seleccionar]
cd "/home/mikkel/.wine/dosdevices/c:/Archivos de programa/FlatOut 2"
Código: [Seleccionar]
wine flatout2.exe
si no inicio correctamente el juego, postea la salida.
« Última modificación: 06 de Mayo de 2011, 10:08:10 am por mint777 »
Fuera de la Net por causas de fuer$a mayor.....come back later.

gilog73

  • Novato
  • *
  • Mensajes: 48
  • Karma: +2/-0
    • Ver Perfil
Re: Juegos no arrancan con Linux Mint 10 64bits
« Respuesta #6 en: 06 de Mayo de 2011, 02:56:46 pm »
Vale , me sale esto pero dejando un espacio entre los comandos :

~/.wine/dosdevices/c:/Archivos de programa/FlatOut 2 $

Pero si pongo después de esto - wine flatout2 -  intenta arrancar pero con el error siguiente :

mikkel@mikkel-P5K-Premium ~/.wine/dosdevices/c:/Archivos de programa/FlatOut 2 $
wine flatout2.exe
err:wgl:X11DRV_WineGL_InitOpenglInfo  couldn't initialize OpenGL, expect problems
err:d3d_caps:WineD3D_CreateFakeGLContext Can't find a suitable iPixelFormat.
err:d3d:InitAdapters Failed to get a gl context for default adapter
Direct3D9 is not available without OpenGL.


Creo entender que tengo un problema con open gl
« Última modificación: 06 de Mayo de 2011, 02:58:53 pm por gilog73 »


mint777

  • Moderador Global
  • Usuario Héroe
  • *****
  • Mensajes: 1820
  • Karma: +118/-1
  • Only 64 bits user
    • Ver Perfil
Re: Juegos no arrancan con Linux Mint 10 64bits
« Respuesta #7 en: 06 de Mayo de 2011, 11:31:11 pm »
Citar
Direct3D9 is not available without OpenGL.

este error indica que no hay aceleracion grafica y puede deberse a:

1.- no estas usando el driver privativo. (esto puede deberse a una mala configuracion o instalacion)
2.- la tarjeta no cuenta con soporte opengl, lo cual queda descartado, porque tu grafica andara por el opengl 4 o 5 y solo se requiere del 2 en adelante.
3.- te hacen falta librerias para usar aceleracion 3d en wine.

De las 2 posibles, vamos desechando la primera, ejecuta en terminal:

Código: [Seleccionar]
glxgears
glxinfo

y posteame las 5 primeras lineas de cada comando.

y por ultimo tambien postea la salida de este comando:

lspci -v -s `lspci | awk '/VGA/{print $1}'`
« Última modificación: 06 de Mayo de 2011, 11:40:48 pm por mint777 »
Fuera de la Net por causas de fuer$a mayor.....come back later.

gilog73

  • Novato
  • *
  • Mensajes: 48
  • Karma: +2/-0
    • Ver Perfil
Re: Juegos no arrancan con Linux Mint 10 64bits
« Respuesta #8 en: 07 de Mayo de 2011, 05:27:26 am »
Otra pregunta , si empleo jdownloader desde la consola , con " jd.sh abrir en un terminal" .Se puede no se abrir una solapa nueva y hacer otras cosas como si tuvieras 2 consolas. No se en una tener corriendo jdwn y en la otra poder ejecutar los comandos para probar lo de glxinfo y glxgears.
O se podría abrir otra consola en otro escritorio .

Uleti

  • Usuario Héroe
  • *****
  • Mensajes: 1496
  • Karma: +117/-57
    • Ver Perfil
Re: Juegos no arrancan con Linux Mint 10 64bits
« Respuesta #9 en: 07 de Mayo de 2011, 06:19:48 am »
Se puede abrir 100000 consolas en el mismo escritorio.

También puedes abrir desde una consola ya abierta otra y crear una solapa. (Archivo-Abrir solapa) o abrir otra nueva terminal (Archivo abrir nueva terminal), aunque para hecer esto último te vasta con darle al icono de terminal, en el menú, las veces que te haga falta.

Abre otra consulta si ya has acabado una. No mezcles.

Saludos.
Saludos.
--

gilog73

  • Novato
  • *
  • Mensajes: 48
  • Karma: +2/-0
    • Ver Perfil
Re: Juegos no arrancan con Linux Mint 10 64bits
« Respuesta #10 en: 07 de Mayo de 2011, 01:48:33 pm »
Te pongo los resultados de glxgears :

90425 frames in 5.0 seconds = 18084.914 FPS
91530 frames in 5.0 seconds = 18305.811 FPS
91399 frames in 5.0 seconds = 18279.660 FPS
91565 frames in 5.0 seconds = 18312.926 FPS
90618 frames in 5.0 seconds = 18123.438 FPS
90697 frames in 5.0 seconds = 18139.316 FPS
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"
      after 52 requests (52 known processed) with 0 events remaining.


Y aqui te dejo el de glxinfo desde pastie.org :

http://pastie.org/1876120

Y el último comando me sale :

01:00.0 VGA compatible controller: nVidia Corporation Device 1200 (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Giga-byte Technology Device 3515
   Flags: bus master, fast devsel, latency 0, IRQ 16
   Memory at fc000000 (32-bit, non-prefetchable) [size=32M]
   Memory at d8000000 (64-bit, prefetchable) [size=128M]
   Memory at d4000000 (64-bit, prefetchable) [size=64M]
   I/O ports at bc00 [size=128]
   [virtual] Expansion ROM at fe800000 [disabled] [size=512K]
   Capabilities: <access denied>
   Kernel driver in use: nvidia
   Kernel modules: nvidia, nouveau, nvidiafb


Quería comentarte que si es un problema con la instalación del driver NVidia , si se puede reinstalar encima ó bien hay que desinstalarlo y voverlo a instalar.
He estado mirando por google instalar driver nvida y desde creo que donde saqué como hacerlo: 

http://virtual-planet.foroactivo.com.es/t1364-howto-instalar-driver-nvidia-en-lmde-201012-y-debian-squeeze-32-y-64-bits

 veo la siguiente opción durante la instalación que dice :

Ahora si estamos instalando el driver en un sistema de 64 bits como es mi caso nos preguntará si queremos instalar las librerías de compatibilidad OpenGL de 32 bits, yo le he dicho que no y he continuado. En los sistemas de 32 bits no saldrá este mensaje.
« Última modificación: 07 de Mayo de 2011, 04:51:48 pm por gilog73 »

gilog73

  • Novato
  • *
  • Mensajes: 48
  • Karma: +2/-0
    • Ver Perfil
Re: Juegos no arrancan con Linux Mint 10 64bits
« Respuesta #11 en: 17 de Mayo de 2011, 04:12:23 pm »
Podríais decirme que he contestado mal en el último post , gracias .


mint777

  • Moderador Global
  • Usuario Héroe
  • *****
  • Mensajes: 1820
  • Karma: +118/-1
  • Only 64 bits user
    • Ver Perfil
Re: Juegos no arrancan con Linux Mint 10 64bits
« Respuesta #12 en: 17 de Mayo de 2011, 09:49:07 pm »
buenas noticias, tienes aceleracion 3d funcionando correcatamente.
investigando en la pagina oficial, he descubierto que el flatout2 se resiste a utilizar la emulacion de la libreria 3d integrada, y por lo tanto, tal vez necesites tunear el wine, aqui esta la guia:

http://lazonalinux.com.ar/post/1498/configuracion-wine-de-alto-rendimiento-comprobado.html

suerte !!

P:D: si no funciona, tendras que copiar una libreria 3d nativa de algun juego que este instalado en windows y luego copiarla a la carpeta correspondiente en wine.
Fuera de la Net por causas de fuer$a mayor.....come back later.

gilog73

  • Novato
  • *
  • Mensajes: 48
  • Karma: +2/-0
    • Ver Perfil
Re: Juegos no arrancan con Linux Mint 10 64bits
« Respuesta #13 en: 18 de Mayo de 2011, 01:49:32 pm »
Gracias en cuanto pueda meterle mano , os digo cosas , de todas formas probaré a instalar otros juegos a ver que tal funciona .
Eeste enlace lo guardo a marcadores , muchas gracias. Aún no h lo he probado pero parece muy completo .
« Última modificación: 21 de Mayo de 2011, 11:15:37 pm por gilog73 »

 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26