torrezno

Autor Tema: sin sonido opensonic(solucionado)  (Leído 3428 veces)

0 Usuarios y 1 Visitante están viendo este tema.

peter

  • Novato
  • *
  • Mensajes: 49
  • Karma: +1/-0
    • Ver Perfil
sin sonido opensonic(solucionado)
« en: 06 de Junio de 2010, 05:46:41 am »
Muy buenas , tengo linuxmint 9 y he instalado opensonic, y no tiene sonido, creo que debe ser algun problema con pulseaudio, porque si lo desinstalo funciona el sonido de sonic, pero al reiniciar el ordenador se queda completamente sin sonido todo el ordenador y reinstalo pulseaudio y vuelvo a tener sonido en todo menos en opensonic.
gracias
« Última modificación: 14 de Junio de 2010, 09:41:42 am por peter »


mint777

  • Moderador Global
  • Usuario Héroe
  • *****
  • Mensajes: 1820
  • Karma: +118/-1
  • Only 64 bits user
    • Ver Perfil
Re: sin sonido opensonic
« Respuesta #1 en: 06 de Junio de 2010, 04:46:51 pm »
efectivamente pulse no se lleva bien con la libreria allegro, por eso aqui te dejo una posible solucion para que no tengas que desinstalar pulse audio.


abrimos terminal y ejecutamos:

Citar
gedit .asoundrc

nos va a salir un documento en blanco, pegamos lo siguiente en ese documento:

Citar
pcm.pulse {
    type pulse
}

ctl.pulse {
    type pulse
}

pcm.!default {
    type pulse
}

ctl.!default {
    type pulse
}

pcm.!dmix {
    type pulse
}

le damos a guardar y luego cerrar.

reiniciamos las x con la combinacion de teclas: ctrl+alt+retroceso

abrimos terminal y ejecutamos:

Citar
sudo gedit /usr/lib/allegro/4.2.2/modules.lst

editamos el documento para que se vea igual a este:

Citar
alleg-vga.so
alleg-fbcon.so
alleg-svgalib.so
alleg-dga2.so
# alleg-esddigi.so
# alleg-artsdigi.so
alleg-sgialdigi.so
# alleg-alsadigi.so
alleg-alsamidi.so
# alleg-jackdigi.so

guardamos y cerramos.

abrimos terminal e instalamos:

Citar
sudo apt-get install alsa-oss

por ultimo abrimos el opensonic con este comando:

Citar
aoss opensonic

pd. a mi me funciona de pelos con estas modificaciones.

saludos ¡¡¡¡
« Última modificación: 06 de Junio de 2010, 04:54:09 pm por mint777 »
Fuera de la Net por causas de fuer$a mayor.....come back later.

peter

  • Novato
  • *
  • Mensajes: 49
  • Karma: +1/-0
    • Ver Perfil
Re: sin sonido opensonic
« Respuesta #2 en: 13 de Junio de 2010, 10:13:40 am »
magnifico :)
muchas gracias


 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26