torrezno

Autor Tema: Touchpad multitouch en LMDE [Casi solucionado]  (Leído 4818 veces)

0 Usuarios y 1 Visitante están viendo este tema.

AnSnarkista

  • Usuario Completo
  • ***
  • Mensajes: 229
  • Karma: +16/-3
  • Siempre libre!
    • Ver Perfil
Touchpad multitouch en LMDE [Casi solucionado]
« en: 20 de Julio de 2011, 04:54:28 am »
Buenas, como sabeis, he estado poniendole a un colega LMDE (Al final se ha quedado con LMDE, que aunque sea un poco mas arduo de consola, es mas estable, y la va a necesitar menos veces).

Tiene un touchpad multitouch, y el netbook en cuestion es un HP mini210. En la instalacion, no tenia activado el scroll horizontal ni las pulsaciones del raton en el touch, pero vas a Preferencias del raton, pestaña Touchpad y las activas y listo.

La cosa es que al estar configurandoselo y tal, me he dado cuenta de que no le funciona el boton derecho, y eso es un problema. Me he puesto a buscar y he encontrado esta solucion:

Código: [Seleccionar]
sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps
wue
 
y crear un archivo /etc/modprobe.d/options en el que este escrito esto:

Código: [Seleccionar]
options psmouse proto=imps
Lo he probado, y funciona, el boton derecho funciona. Pero me desactiva el scrolling vertical/horizontal.

He leido http://wiki.debian.org/SynapticsTouchpad , pero ese ordenador (ni el mio tampoco), tiene archivo xorg.conf.

Hay un apartado de cómo crearlo, pero no se si eso puede hacer que se desestbilice o cree algun tipo de problema.

Y despues, si no es "peligroso" el xorg.conf ¿como configurarlo para que tenga ambas opciones? Para esta pregunta trasteare un poco antes...que siempre es interesante exprimir un poco las opciones...jeje
« Última modificación: 27 de Julio de 2011, 05:46:31 pm por AnSnarkista »
Salud!

LMDE con Gnome Session Fallback...todo un lujo


cargoan

  • Usuario Sr.
  • ****
  • Mensajes: 302
  • Karma: +27/-0
    • Ver Perfil
Re: Touchpad multitouch en LMDE
« Respuesta #1 en: 20 de Julio de 2011, 08:10:35 pm »
Ahí mismo te lo explican, en lugar de xorg.conf se utiliza el directorio /etc/X11/xorg.conf.d, crea ahí un archivo con extensión .conf con la configuración que desees ponerle.
http://wiki.debian.org/SynapticsTouchpad#Debian_squeeze.2C_kernel_2.6.32-4_and_later.2C_Xorg_7.5
« Última modificación: 20 de Julio de 2011, 10:04:32 pm por cargoan »
Linux User #461067

AnSnarkista

  • Usuario Completo
  • ***
  • Mensajes: 229
  • Karma: +16/-3
  • Siempre libre!
    • Ver Perfil
Re: Touchpad multitouch en LMDE
« Respuesta #2 en: 21 de Julio de 2011, 02:59:45 am »
Tampoco tengo el directorio /etc/X11/xorg.conf.d....entonces no se...jeje

La cosa es si hago lo que pone para crear el archivo xorg.conf, o creo un directorio /etc/X11/xorg.conf.d y dentro meto un archivo con extension .conf

Muchas gracias!


EDITO:

El directorio xorg.conf.d, lo tengo en /usr/share/xorg.conf.d. He mirado dentro, y hay un archivo llamado 50-synaptics.conf, y paso a poner lo que contiene:

Código: [Seleccionar]
# Example xorg.conf.d snippet that assigns the touchpad driver
# to all touchpads. See xorg.conf.d(5) for more information on
# InputClass.
# DO NOT EDIT THIS FILE, your distribution will likely overwrite
# it when updating. Copy (and rename) this file into
# /etc/X11/xorg.conf.d first.
# Additional options may be added in the form of
#   Option "OptionName" "value"
#
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
#       MatchDevicePath "/dev/input/event*"
EndSection


Pero dentro de /etc/X11/ no tengo la carpeta xorg.conf.d...la creo y meto una copia de ese archivo renombrado en el?
« Última modificación: 21 de Julio de 2011, 04:52:20 am por AnSnarkista »
Salud!

LMDE con Gnome Session Fallback...todo un lujo


cargoan

  • Usuario Sr.
  • ****
  • Mensajes: 302
  • Karma: +27/-0
    • Ver Perfil
Re: Touchpad multitouch en LMDE
« Respuesta #3 en: 21 de Julio de 2011, 08:17:42 pm »
Sí, le puedes añadir la configuración que necesites. Yo descomentaría la línea MatchDevicePath "/dev/input/event*", para evitar que lo detecte dos veces, como  /dev/input/eventX y como /dev/input/mouseX. 

el xorg.conf aunque obsoleto también puede utilizarse, puedes usar este método también, pero...
eso, que su uso está obsoleto.
« Última modificación: 21 de Julio de 2011, 08:51:51 pm por cargoan »
Linux User #461067

AnSnarkista

  • Usuario Completo
  • ***
  • Mensajes: 229
  • Karma: +16/-3
  • Siempre libre!
    • Ver Perfil
Re: Touchpad multitouch en LMDE
« Respuesta #4 en: 27 de Julio de 2011, 05:45:23 pm »
Ya he descubierto la unica forma efectiva de hacer esos cambios, pero no de que perduren...

Código: [Seleccionar]
synclient Propiedad=Valor (las propiedades y los valores posibles, se ven en man 4 synaptics)

He probado a crear el archivo synaptics.conf dentro de /etc/X11/xorg.conf.d y nada (como pone en el archivo ubicado en /usr/share/xorg.conf.d/50-synaptics.conf) y a crear el xorg.conf, pero no va ninguno de los dos.

Ademas, cuando he cambiado alguna propiedad mediante el comando synclient Propiedad=Valor, y despues he hecho synclient -l, en la salida, si me muestra el cambio que yo he hecho, pero no en ninguno de los archivos.

Se puede cambiar, pero no sé como dejarlo guardado esos cambios. Incluso haciendo los cambios mediante consola con synclient, luego al abrir gnome-mouse-properties, o gpointing-device-settings, me detecta los cambios y aparecen las opciones marcadas o cambiadas.

Asi que con el comando synclient, cambia efsjdectivamente, pero no lo guarda, y luego las aplicaciones para configuracion del touch las detecta.

Por ultimo he intentado abrir uno de los dos gestores de opciones para teclado, y despues el monitor del sistema y boton derecho sobre el proceso para intentar ver los archivos que tiene abierto, pero nada tampoco.

Finalmente, y como ultima prueba, he probado de nuevo:

Código: [Seleccionar]
sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps

y despues synclient -l, y me decia que no habia ningun synaptic conectado. De esa manera, si me reconoce el boton derecho, asi que lo que intuyo, es que el driver synaptic, no detecta el boton derecho de los multitouch, asi que mire de nuevo synclient -l, y vi que la propiedad TapButton2 (tocar el teclado con 2 dedos), tenia el evento 3, que seria como clikear con el boton derecho, y TapButton3 (tocar el touch con 3 dedos), el evento 2, que es el boton de enmedio, asi que le digo a mi colega que si quiere darle al boton derecho, tap con dos dedos, y para el de enmedio, tap con 3 dedos.

PD: He leido tambien que hay otra propiedad que se llama ClickFingerX (X solo puede ser 1, 2 o 3), cuya descripcion es la siguiente:

Código: [Seleccionar]
Which mouse button is reported when left-clicking with X  fin‐
              ger.  Set to 0 to disable. Property: "Synaptics Click Action"

[EDITO]

Justo estaba escribiendo esta linea, cuando se me ha encendido la lucecita!!!!

ClickFinger1 = Qué evento salta cuando pulsas el boton derecho con UN dedo (que tolai soy, sé que significaba, pero no me daba cuenta de que aqui está el fallo!!)
Normalmente, se clikea con un solo dedo, pues casualmente, está puesto como ClickFinger1=1, por tanto, cuando clikeas NORMALMENTE (osease con UN dedo) en el boton derecho, ¡Se detecta como un boton izquierdo!, osea que parece como que no detecta el boton derecho, cuando SÍ que lo hace (perdon por dudar de ti, soft libre!!).

Con un simple
Código: [Seleccionar]
synclient ClickFinger1=3es suficiente!!

Ahora, sólo se me ocurre una idea para mantenerlo, o poner ese comando en aplicaciones al inicio (solucion chunga), o, probar a ver si es que he hecho mal lo del xorg.conf / xorg.conf.d, que volvere a probar.
Salud!

LMDE con Gnome Session Fallback...todo un lujo

cargoan

  • Usuario Sr.
  • ****
  • Mensajes: 302
  • Karma: +27/-0
    • Ver Perfil
Re: Touchpad multitouch en LMDE [Casi solucionado]
« Respuesta #5 en: 27 de Julio de 2011, 08:52:53 pm »
En el archivo de configuración de /etc/X11/xorg.conf.d añade la línea: Option "ClickFinger1" "3" y así el cambio será persistente.

Yo eliminaría o renombraría el xorg.conf si has copiado el archivo de synaptics en xorg.conf.d y así utilizar la detección automática de xorg.
Linux User #461067

Cain Corleone

  • Usuario Jr
  • **
  • Mensajes: 51
  • Karma: +4/-0
  • Una vez que ves el verde, no lo podrás dejar.
    • Ver Perfil
Re: Touchpad multitouch en LMDE [Casi solucionado]
« Respuesta #6 en: 15 de Enero de 2012, 09:37:17 pm »
AnSnarkista y carogan:

Desconozco si todavía AnSnarkista aún tiene el problema, realmente lo dudo; pero esto lo pongo para toda la comunidad pues apenas pude resolverlo en mi Dell Inspiron 15R (N5110). Pero instalé este driver y al reiniciar todo fue de maravilla. Mi mouse ya era reconocido como un touchpad y la velocidad del mismo aumentó considerablemente, funcionaba el scroll y no sé del multicouch (pues yo no lo uso).


Fuente: [link]http://ubuntuforums.org/showthread.php?t=1887683[/link]


AnSnarkista

  • Usuario Completo
  • ***
  • Mensajes: 229
  • Karma: +16/-3
  • Siempre libre!
    • Ver Perfil
Re: Touchpad multitouch en LMDE [Casi solucionado]
« Respuesta #7 en: 16 de Enero de 2012, 03:58:49 am »
Ya mi compañero se ha acostumbrado a como se lo dejé, asi que no hace falta ya jeje

De todas formas, muchas gracias, para probables futuros inciertos....jajajaja
Salud!

LMDE con Gnome Session Fallback...todo un lujo

Camiloalcubo

  • Usuario Jr
  • **
  • Mensajes: 88
  • Karma: +1/-0
    • Ver Perfil
Re:Touchpad multitouch en LMDE [Casi solucionado]
« Respuesta #8 en: 01 de Mayo de 2013, 06:12:30 pm »
Hola, ¿sabes?
Yo partí con el mismo ptoblema tuyo en mi touchpad. En un principio vi que no me funcionaba el dejar un dedo sobre el botón izquierdo y mover el cursor con la otra mano, porque se trababa todo, y que tampoco me funcionaba el botón derecho del mouse para las opciones. Intenté una infindad de cosas, entre ellas, las que aparecen en este foro, y no me funcionaron del todo bien. La que mejor andubo me reconocía los dos dedos sobre el touchpad, pero con dos dedos sobre éste, la velocidad del cursor era lentísima, coo si un dedo frenara al otro. Después me di cuenta de que sí podía dejar el dedo sobre el touchpad y usar el otro dedo (que es lo que necesitas para seleccionar varios íconos con el touchpar, por ejemplo.. y que con el mouse resulta al cliquear y, sin soltar, mover el mouse). La forma en que debía hacerlo, era dejar el dedo en la esquina inferior izquierda (nada nuevo hasta aquí), pero muy muy enla esquina, casi la punta del dedo, y con eso me ha funcionado bien. Lo otro, del botón derecho, lo descubrí hace unos días y funciona al cliquear en la esquina inferior derecha con dos dedos. Esto equivaldría a usar el botón derecho del mouse, que en el touchpad de nosotros no funcionaba. es bastante sencillo, y la zona que reconoce los dedos es más grande que la que reconoce a los dedos en la zona izquierda.
Supongo que son cosas a las que uno está dispueso a acostumbrarse con tal de usar Linux. Yo transo frente a eso y ahora lo hago porque ninguna solución me era útil.
Espero que de algo sirva, a quien enre a leer esto. No es una solución, o sea, quizás sí, pero no pasa por instalar ni cambiar nada, sólo pasa por cambiar la forma en que usas el touchpad.
Saludos a todos :D

AnSnarkista

  • Usuario Completo
  • ***
  • Mensajes: 229
  • Karma: +16/-3
  • Siempre libre!
    • Ver Perfil
Re:Touchpad multitouch en LMDE [SOLUCIONADO]
« Respuesta #9 en: 02 de Mayo de 2013, 02:42:44 pm »
Ahora que has reabierto el hilo, os coloco la solucion total al "problema", es un simple error de configuracion, nada mas. Me robaron el portatil, y he estado probando otras distros, y probando Fuduntu, me di cuenta de que el "error" del touch estaba solucionado, así que en la terminal, puse "synclient", para ver los parametros que estaban puestos, y todo este tema radica en que las propiedades "RightButtonAreaLeft" y "RightButtonAreaTop" (Márgenes izquierdo y superior del boton derecho. El margen derecho, da igual, porque está el borde físico del touch), están puestos a 0, por tanto, no hay área de boton derecho, es todo el boton izquierdo. En mi caso, cambiando esos parametros a 1624 y 1822 respectivamente, se hace el mapeo del boton derecho, funcionando el clikearlo, y mover el puntero, y demas cosas.


Coloco el [SOLUCIONADO] de forma definitiva.
Salud!

LMDE con Gnome Session Fallback...todo un lujo

 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26