torrezno

Autor Tema: [solucionado]Drivers de nvidia en Linux Mint Debian  (Leído 10907 veces)

0 Usuarios y 1 Visitante están viendo este tema.

tavomazzei

  • Novato
  • *
  • Mensajes: 9
  • Karma: +0/-0
    • Ver Perfil
[solucionado]Drivers de nvidia en Linux Mint Debian
« en: 01 de Octubre de 2010, 05:29:43 am »
Hola a toda la buena gente de este foro.Logre hacer andar mi modem 3G Gracias a un amigo que me paso los paquetes y la ayuda de uleti.
El problema que estoy teniendo ahora es al instalar los controladores de video.Les cuento como lo hice:
Fui a la pag de nvidia busque mi driver ,Abri una tty y detuve las X de este modo #/etc/init.d/gdm3 stop y me ubique en el directorio donde descargue el archivo .run.Lo ejecute y al entrar al entorno grafico todo seguia igual asi que reinicie y jamas inicio.Reconfigure la grafica pero tampoco pude encontrar el archivo xorg.conf en /etc/X11
Reinstale y desp intente instalarlo a traves de module assistant y volvi a romper asi que estoy medio perdido. si por favor me pueden orientar les agradeceria mucho
« Última modificación: 04 de Octubre de 2010, 05:12:34 am por tavomazzei »


Miguel BOFH

  • Moderador Global
  • Usuario Héroe
  • *****
  • Mensajes: 2416
  • Karma: +110/-5
  • Se volverán uno con los Borg
    • Ver Perfil
Re: Drivers de nvidia en Linux Mint Debian
« Respuesta #1 en: 01 de Octubre de 2010, 08:55:45 am »
El primer error que tuviste es instalar el .bin de Nvidia y el segundo volver a instalarlo con module-asistant ,para su posible solución de la primera:

# nvidia-uninstall

Para la segunda:

# aptitude purge nvidia

Hacemos una limpieza con:

#m-a clean nvidia

Ahora volvemos a instalar nvidia con module-assistant :

# aptitude install module-assistant
# m-a prepare
# m-a a-i nvidia

#aptitude install nvidia-glx

La ruta de del xorg tiene que estar en /etc/X11/xorg.conf , pero recuerdo que en Debian testing en sus inicios con nvidia se generaba otro propio ,si te sirve de ayuda te dejo el mio , para ver el tuyo entras con live-cd  tipo ubuntu,linuxmint... abres una terminal y colocas sudo su.

Código: [Seleccionar]
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildd@barber)  Sun Jun 13 12:08:56 UTC 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection



« Última modificación: 01 de Octubre de 2010, 09:07:41 am por Miguel BOFH »

User2

  • Usuario Héroe
  • *****
  • Mensajes: 1778
  • Karma: +70/-0
  • Vamos Cristina carajo!!! Cuatro años mas! ;)
    • Ver Perfil
Re: Drivers de nvidia en Linux Mint Debian
« Respuesta #2 en: 02 de Octubre de 2010, 06:05:17 am »
En mi caso lo instalé en Debian de la siguiente manera y va perfecto!
Compiz y emerald a todo lujo!  ;)

Citar
# aptitude install module-assistant
# m-a prepare
# m-a a-i nvidia
# apt-get install nvidia-settings nvidia-xconfig
#nvidia-xconfig



tavomazzei

  • Novato
  • *
  • Mensajes: 9
  • Karma: +0/-0
    • Ver Perfil
Re: Drivers de nvidia en Linux Mint Debian
« Respuesta #3 en: 04 de Octubre de 2010, 05:11:28 am »
En mi caso lo instalé en Debian de la siguiente manera y va perfecto!
Compiz y emerald a todo lujo!  ;)

Citar
# aptitude install module-assistant
# m-a prepare
# m-a a-i nvidia
# apt-get install nvidia-settings nvidia-xconfig
#nvidia-xconfig



Gracias ya consegui hacerlo andar,disculpen que me demore en responder es que estaba con trabajo.
tu solucion seguro anda ya que hice lo mismo pero sin esto
# apt-get install nvidia-settings nvidia-xconfig
#nvidia-xconfig
Asi que al reiniciar el sistema no arranco y en modo de recuperacion genere un archivo xorg.conf de este modo

Xorg -configure

y lo movi a /etc/X11:
mv /root/xorg.conf.new /etc/X11/xorg.conf

Siempre hago una de mas en este caso hice una de menos
Muchisimas gracias por la ayuda!!!
por cierto el sistema tiene exelentwe aceleracion 3d y compiz se ve genial solo tuve que poner el comando:
compiz --replace
para que inicie con el sistema

Otra cosa que hice que me daba problemas es poner el driver noveau a blacklist

reinaldofotografia

  • Novato
  • *
  • Mensajes: 4
  • Karma: +0/-0
    • Ver Perfil
Re: [solucionado]Drivers de nvidia en Linux Mint Debian
« Respuesta #4 en: 11 de Febrero de 2011, 09:32:51 am »
saludos a mi me sale este error


gatopardo

  • Usuario Jr
  • **
  • Mensajes: 75
  • Karma: +1/-0
    • Ver Perfil
Re: [solucionado]Drivers de nvidia en Linux Mint Debian
« Respuesta #5 en: 11 de Febrero de 2011, 12:43:14 pm »
A mi despues de instalar como decis, al reiniciar,pantalla negra con el cursor en la esquina superior izquierda.:
He hecho lo que dice "tavomazzei":

"Al reiniciar el sistema no arranco y en modo de recuperacion genere un archivo xorg.conf de este modo"

Xorg -configure

"y lo movi a /etc/X11:"
mv /root/xorg.conf.new /etc/X11/xorg.conf

¡¡Y ha funcionado!!

Gracias
« Última modificación: 11 de Febrero de 2011, 02:53:35 pm por gatopardo »

User2

  • Usuario Héroe
  • *****
  • Mensajes: 1778
  • Karma: +70/-0
  • Vamos Cristina carajo!!! Cuatro años mas! ;)
    • Ver Perfil
Re: [solucionado]Drivers de nvidia en Linux Mint Debian
« Respuesta #6 en: 12 de Febrero de 2011, 02:30:12 pm »
Reinaldo, no se puede ver el error.
Cómo lo estas instalando?
Con lo que posteo Miguel o yo??


MegaMauricio

  • Novato
  • *
  • Mensajes: 21
  • Karma: +0/-0
  • <INSERTAR UN TEXTO PERSONALIZADO AQUÍ>
    • Ver Perfil
    • Mi Deviantart
Re: [solucionado]Drivers de nvidia en Linux Mint Debian
« Respuesta #7 en: 01 de Julio de 2012, 08:39:49 pm »
Perdón por revivir este tema que está solucionado, pero a mí me aparece un problema: cuando intenté actualizar el driver de la tarjeta  de video en LMDE (Nvidia GT220) y me advertía de que habrían conflictos con el anterior driver, o algo así, y cuando reinicio solo aparecen letras negras y unas pantallas que dicen que el servidor X esta ahora desactivado. Reinicie MDM cuando esté configurado correctamente.
He probado los comandos que han dado en este tema en el modo de recuperación pero sigue igual y no puedo editar el Xorg desde el terminal.

Se agradece la ayuda.

EDITADO
Bueno, he solucionado el problema y he vuelto al entorno gráfico. Hice algo algo enredado y comenzó con darme por vencido y reinstalar LMDE encima del anterior (pensando que con eso se sobrescribiría todo y volvería a empezar de cero), sin embargo, el problema continuaba: "Falló al iniciar el servidor X..." pero ahora me daba la opción de iniciar con mi nombre de usuario y contraseña (antes solo me pedía la contraseña) ¿Por qué ese mensaje me molestaba todavía, incluso después de reinstalar todo? el caso es que buscando por internet probé muchas cosas y entre las cuales un comando dio la salvación estando en esa oscuridad (en el modo texto) y con el gdm desactivado:

Código: [Seleccionar]
X -configureReiniciar el servidor X:
Código: [Seleccionar]
/etc/init.d/gdm start ; exit Se crea el archivo de configuración en /root
Luego se copia a donde corresponde:
Código: [Seleccionar]
cp /root/xorg.conf.new /etc/X11/xorg.confY reinicié y ¡Ding! Pude volver a ver la pantalla de bienvenida  ;D
Lo que más me sorprendió fue que mantenía todas mis cosas de antes (fondo, iconos, configuraciones y archivos) y es como si no hubiera pasado nada. El único detallito es que me quedé con la configuración básica del driver de video (VESA) y, aunque lo noto igual en rendimiento grafico que antes, no me muestra el cinnadock que lo tenía activado.

Mi lucha por hacer funcionar los drivers de nvidia en linux continúa, para disfrutar de aceleración gráfica de alta calidad y debo decir que aprendí mucho con este obstáculo (entre los innumerables intentos que hice para rescatar el sistema)

« Última modificación: 16 de Julio de 2012, 08:06:19 pm por MegaMauricio »

 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26