Linux Mint Comunidad Hispana

Soporte => Soporte Software => Mensaje iniciado por: AnSnarkista en 18 de Junio de 2011, 04:12:30 pm

Título: Instalar AWN-Lucido en LMDE [Solucionado]
Publicado por: AnSnarkista en 18 de Junio de 2011, 04:12:30 pm
Tengo instalado el AWN que viene en los repositorios de Debian y por defecto en LMDE, pero esta version de AWN no tiene la opcion del tema "Lucido" y la verdad es que es la leche y me gustaria instalarlo, pero no se como. He seguido tutoriales que decian que habia que añadir repositorios ( http://ppa.launchpad.net/awn-testing/ppa/ubuntu maverick main) pero cuando hago el intento de instalarlo, me salen errores de dependencias a saco. Si intento instalar el avant-window-navigator-trunk, me dice que depende del avant-window-navigator-data-trunk, que no va a ser instalado. Si pongo primero el data-trunk, me dice que depende del otro, que no va a ser instalado, si pongo los dos juntos para marcarlos, me dice que el avant-window-navigator-trunk no va a ser instalado....

Si pongo en una consola sudo apt-get install y todos los paquetes, me dice que hay dependencias incumplidas, pero que no son instalables...me dice que libindicator1 no es instalable, lo busco en internet, lo descargo y lo instalo, y ZAS! me salta el gestor de actualizaciones diciendo que algo falla, sudo apt-get -f install, y me dice que tengo que eliminar el libindicator1...

 Lo unico que me falta es bajarme las dependencias por paquetes uno a uno e irlos instalando, pero es que son paquetes de Ubuntu, entocnes no se si en LMDE va a funcionar bien y no va a haber problemas.

No idea....alguien me puede ayudar? jajajajajaaj

Salud!

[Edito]

Hoy he actualizado, y ya esta en los repos de LMDE el AWN con el tema Lucido, asi que eso, coloco el solucionado
Título: Re: Instalar AWN-Lucido en LMDE
Publicado por: mint777 en 18 de Junio de 2011, 11:09:04 pm
no, no y no, RECUERDEN usuarios de LMDE, tratar su sistema como ubuntu puede resultar en un sistema ROTO, tal y como le paso a un usuario de este foro hace unos dias y que al final debe reinstalarlo.

esto que hiciste:
Citar
http://ppa.launchpad.net/awn-testing/ppa/ubuntu maverick main)

añadir un repo ubuntu a tu debian (lmde) es peligrosisimo.

volviendo al tema:

No se hasta que punto tu sistema se haya llenado de paquetes peligrosos provenientes de el repo PPA, pero para tener la ultima version de awn en LMDE, debes compilarlo:

http://wiki.awn-project.org/InstallingFromSource#AWN_From_Source
 

Título: Re: Instalar AWN-Lucido en LMDE
Publicado por: AnSnarkista en 19 de Junio de 2011, 12:51:26 am
Oppppssss!!! Muchisimas gracias por la info. Realmente, añadi ese repo, e intente instalar los paquetes, pero los he eliminado todos, porque lei en este foro eso mismo, que instalar paquetes de Ubuntu era peligroso (no entiendo porque, porque si se supone que Ubuntu proviene de Debian, deberian valer igualmente no?), asi que por eso no lo hice del tiron.

Vale, he de cambiar el chip ubuntero,esto es Debian, no Ubuntu.

De todas formas, da un poco igual, porque en breves voy a tener que reinstalarlo, ya que en este ordenador tengo Katya y LMDE, que lo instale para probarlo, y me parece que es el que se va a quedar.

Entonces a prtir de ahora, cada vez que quiera instalar algo, lo voy a tener que compilar (anque no se que significa...jajajaj) y demas no?.

Muchas gracia!
Título: Re: Instalar AWN-Lucido en LMDE
Publicado por: mint777 en 19 de Junio de 2011, 01:50:56 pm
Citar
De todas formas, da un poco igual, porque en breves voy a tener que reinstalarlo, ya que en este ordenador tengo Katya y LMDE, que lo instale para probarlo, y me parece que es el que se va a quedar.

te puedes quedar con los 2 si quieres, digo si dispones de espacio y tiempo para las 2 versiones.  ;)

Citar
Entonces a partir de ahora, cada vez que quiera instalar algo, lo voy a tener que compilar (anque no se que significa...jajajaj) y demas no?.

No, yo personalmente (aunque me encanta la compilacion) sigo este "walktrought" para encontrar paquetes instalables para mi LMDE:

1.- La mejor forma:
Repos oficiales (synaptic, consola, etc)

2.- Busqueda, descarga e instalacion desde sid/experimental (repos con paqueteria mas nueva)
Abro el navegador web e ingreso a la pagina oficial de busqueda de paquetes Debian ---> http://www.debian.org/distrib/packages
acto seguido, busco donde dice "Búsqueda en los directorios de paquetes" e introduzco el nombre del paquete a localizar y el repo donde quiero hacer la busqueda (sid o experimental)
cuando este en la pagina del paquete, busco el link para descargarlo y una vez descargado, como son paquetes .deb, con doble clik se instalan.

3.- Google:
hago una busqueda en google con estos parametros: "nombredelpaquete.deb"

4.- por ultimo, si aun no encuentro nada, hago la busqueda de la pagina oficial del paquete: "nombredelpaquete pagina oficial"
por lo general, casi siempre me encuentro con ejecutables (.deb o precompilados), solo en caso de tratarse de paquetes muy nuevos, es cuando me topo con la compilacion (por obvias razones, ya que los desarrolladores por lo general empaquetan software estable).
saludos
Título: Re: Instalar AWN-Lucido en LMDE
Publicado por: AnSnarkista en 25 de Junio de 2011, 04:23:51 am
+1, muchisimas gracias por ese aporte, ha sido lo que me esta salvando el culo estos dias jeje.

He aprendido incluso a intalar .tar.gz, que antes no sabia ni nada (usaba alien para hacerlos .deb), pero bueno, mejor instalarlos del tiron. Lo que pasa es que he tenido un problema (ahora estoy desde Katya otra vez). Bueno, el problema generado por no-se-que (supongo que sera la instalacion de algun paquete) no me deja abrir la sesion grafica, pero eso lo abro en otro post mejor no?
Título: Re: Instalar AWN-Lucido en LMDE
Publicado por: AnSnarkista en 25 de Junio de 2011, 09:07:17 am
Bueno, lo de la grafica esta solucionado ya.

Te puedo pedir un favor? No he conseguido todavia instalar el AWN de la ultima version (el que viene con el tema Lucido, que viene en Ubuntu Natty por defecto), asi que si puedes intentartelo instalar tu, y decirme si se puede o si no se puede instalar. En caso de que se pueda, irme enseñando como deberia de ir haciendo las cosas, pero sin decirmelo paso a paso, que me gusta eso de investigar y probar cosas. Ademas, ahora me gustaria aprender a hacer cosas de estas para no tener que estar cada vez que necesite algo pidiendo ayuda.

Aun asi, muchisimas gracias por el anterior post, que no sabes lo que me ha ayudado.

Salud!
Título: Re: Instalar AWN-Lucido en LMDE
Publicado por: mint777 en 25 de Junio de 2011, 09:42:53 am
lo intentaré, solo dime en cual version ¿LMDE o LM 11?
Título: Re: Instalar AWN-Lucido en LMDE
Publicado por: AnSnarkista en 25 de Junio de 2011, 09:49:44 am
Estoy en LMDE, porque en el repositorio de Katya, es el que viene por defecto. Si instalas AWN en Katya, te viene ya esa version.

Ahora estoy haciendo progresos, ya posteo esta noche si lo consigo.

gracias!

[EDITADO]

Bueno a ver, esto es lo que he conseguido:

He intentado hacerlo por dos metodos que señala en la pagina donde me has indicado:

METODO 1: Crear mi propio .deb (http://wiki.awn-project.org/HOWTO:BuildYourOwnDebianPackages)

1 y 2 -He comprobado que no tengo instalado ningun paquete de avant-window-navigator, ni ninguno que comience con libawn*.

3 -Creo el bzr branch (no se que es, pero cuando pongo el comando que pone, bzr co lp:awn, me crea una carpeta en el home que se llama awn, asi que he supuesto que ese es el "branch" no?)

4 -Instalo a mano cada uno de los paquetes que tiene como dependencia. (Los que salen en cursiva segun http://wiki.awn-project.org/Dependency_Matrix para hacerlo desde el source). Si escribo el sudo apt-get build-dep avant-window-navigator, me dice que no se puede encontrar un paquete de fuentes para avant. -->[Edito]- He abierto el sources.list, y he duplicado los repositorios que tenia, pero añadiendo deb-src etc...para poder obtener los codigos fuente, y lo he vuelto a escribir (sudo apt-get build-dep avant-window-navigator) y ahora me dice que 0 actualizados, 0 se instalaran, 0 para eliminar y 5 no actualizados.
 
5 -Abro la carpeta awn que esta en el home, boton derecho y selecciono "Abrir en un terminal", asi ya no tengo que escribir la primera parte del siguiente comando (cd avant-window-navigator), porque ya esta en ella la consola. Asi que escribo la segunda parte: dpkg-buildpackage -rfakeroot.
Tras esto, salen muchas cosas seguidas y demas (intuyo que entonces esta bien hecho por ahora), hasta que al final sale:
Citar
checking for AWN... no
configure: error: Package requirements (glib-2.0 >= 2.16.0 gthread-2.0 gobject-2.0 desktop-agnostic >= 0.3.91 gtk+-2.0 >= 2.12.0 gdk-2.0 >= 2.12.0 dbus-glib-1) were not met:

Requested 'desktop-agnostic >= 0.3.91' but version of libdesktop-agnostic is 0.3.90

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables AWN_CFLAGS
and AWN_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
make: *** [build-stamp] Error 1
dpkg-buildpackage: fallo: debian/rules build devolvió un estado de salida de error 2

Creo que lo que falla aqui es el paquete libdesktop-agnostic, que se necesita la version 0.3.91. He buscado como me dijiste el paquete ese siguiendo tus pasos y no lo he encontrado...
Otra cosa que pasa es que en el home se me crean dos archivos, avant-window-navigator-trunk_0.4.1+bzr-0ubuntu1.dsc y avant-window-navigator-trunk_0.4.1+bzr-0ubuntu1.tar.gz, y no se si ese .tar.gz es instalable o si no, ya que en el nombre pone ubuntu.

METODO 2: Instalar desde source code (http://wiki.awn-project.org/InstallingFromSource)

Con el paso 1, 2 y 3 anteriores, ya tengo todo preparado no? Lo que he hecho ha sido sacar las carpetas anteriores del home, y empezar de nuevo:

1 - bzr co lp:awn hace lo mismo que en el metodo anterior, crea la carpeta awn en el home.

2 -Voy a la carpeta en cuestion, abriendo el home, y dandole a Abrir en un terminal.

3 - Hago el ./autogen.sh y salen otro monton de cosas, y al final, acaba de la misma manera que en el caso anterior.

Voy a intentar buscar mas el dichoso libdesktop-agnostic 0.3.91 o superior...puede ser eso el motivo de que no funcione nada de eso no??


Título: Re: Instalar AWN-Lucido en LMDE
Publicado por: mint777 en 26 de Junio de 2011, 03:09:59 pm
Ya lo intenté, y descubri que el problema es la configuracion Gnome-ubuntu que tiene LMDE, compruebalo tu mismo:

El paquete principal que impide la compilacion se llama libfontconfig , buscalo en synaptic y podras ver que tiene empaquetamiento ubuntu.
Si intento forzar la instalacion de el paquete testing de libfontconfig, me pide eliminar casi por completo el escritorio Gnome.
Lo siento, una vez mas se comprueba las dificultades que ocasiona un sistema hibrido Debian-ubuntu.
Título: Re: Instalar AWN-Lucido en LMDE
Publicado por: AnSnarkista en 26 de Junio de 2011, 03:33:28 pm
Como te he escrito antes (lo he hecho paso a paso), nunca me ha puesto ningun problema con libfontconfig...era con el libdesktop-agnostic, que tiene que tener una version mas.

Voy a seguir mirandolo...jeje

[EDITADO]

No se podria hacer nada con informacion de esta pagina? https://launchpad.net/ubuntu/+source/libdesktop-agnostic/0.3.92-0ubuntu2
La cosa es que es de Ubuntu tambien...no se...
Título: Re: Instalar AWN-Lucido en LMDE
Publicado por: mint777 en 26 de Junio de 2011, 09:18:05 pm
Bien, para poder correr hay que saber caminar. Vamos por partes y desde el comienzo:

1.- El primer paso es la desinstalacion de cualquier awn, completado con exito.
2.- El segundo paso es cumplir con las dependencias:
glib  -----> sudo apt-get install libglib2.0-dev  ----> prueba superada.
gtk  ------> sudo apt-get install libgtk2.0-dev  ----> prueba no superada

Código: [Seleccionar]
Los siguientes paquetes tienen dependencias incumplidas:
 libgtk2.0-dev : Depende: libpango1.0-dev (>= 1.20) pero no va a instalarse
                 Depende: libcairo2-dev (>= 1.6.4-6.1) pero no va a instalarse
E: Paquetes rotos

Intento instalar libpango1:

sudo apt-get install libpango1.0-dev

Código: [Seleccionar]
Los siguientes paquetes tienen dependencias incumplidas:
 libpango1.0-dev : Depende: libxft-dev pero no va a instalarse
                   Depende: libfontconfig1-dev (>= 2.1.91) pero no va a instalarse
                   Depende: libcairo2-dev (>= 1.8.2-2) pero no va a instalarse
E: Paquetes rotos

Como puedes observar aqui ya aparece el principal causante.
Abro synaptic e investigo y descubro que los 3 paquetes anteriores son empaquetados de ubuntu  :o
Intento solucionarlo forzando la sustitucion por los paquetes correctos:

Abrimos synaptic, seleccionamos el paquete libcairo2 y le damos a forzar version (eliminar la ubuntu e instalar la testing)  -----> prueba superada.
Repetimos el paso anterior con libfontconfig1 --------> prueba no superada, requiere la eliminacion de casi todo gnome.

La pregunta obligada es, ¿como le hiciste para instalar libgtk2.0-dev?

Título: Re: Instalar AWN-Lucido en LMDE
Publicado por: AnSnarkista en 26 de Junio de 2011, 11:26:36 pm
Pues esos que me dices los tengo instalados y sin problemas...realmente no me dieron problemas al instalarlos.

libpango1.0-dev  1.28.3-6

libglib2.0-dev       2.28.6-1

libxft-dev              2.2.0-3

libcairo2-dev        1.10.2-2ubuntu2

libgtk2.0-dev       2.24.4-3

libfontconfig1-dev     2.8.0-2.1ubuntu3

No se como estan ahi....pero estan...jajajajaja

Puede ser porque haya puesto en el sources.list repositorios para intentar instalarlo desde repo y que no den problemas? Ayer hice limpieza de repos porque como me dijiste que no usasa repos de Ubuntu por los posibles problemas, deje los que tenia por defecto.

Esos paquetes que tengo instalados no me dan problemas por ahora, ni tengo rotos ni con dependencias incumplidas ni nada por el estilo.
Título: Re: Instalar AWN-Lucido en LMDE
Publicado por: mint777 en 27 de Junio de 2011, 08:00:58 am
Citar
libfontconfig1-dev     2.8.0-2.1ubuntu3

Aqui esta la respuesta a mi pregunta, instalaste ya sea por repos externos o manualmente el libfontconfig1-dev empaquetado por ubuntu.
Ese si permite el sistema la instalacion, pero el objetivo es lo contrario, de lo que se trata es de limpiar al sistema de dependencias ubunteras.
Para poder lograr una compilacion al estilo Debian, se requiere que todas las dependencias sean empaquetadas por Debian.Mientras no sea asi jamas vamos a lograr la compilacion.
Y tampoco vamos a lograr la compilacion al estilo Ubuntu mientras las dependencias tengan empaquetado Debian.

Citar
ni tengo rotos

Tampoco yo, simple y sencillamente el APT me señala que no puede instalar tal o cual paquete porque quedarian algunos rotos, es como una advertencia.

Citar
ni con dependencias incumplidas ni nada por el estilo.

si tienes dependencias incumplidas.

Citar
configure: error: Package requirements (glib-2.0 >= 2.16.0 gthread-2.0 gobject-2.0 desktop-agnostic >= 0.3.91 gtk+-2.0 >= 2.12.0 gdk-2.0 >= 2.12.0 dbus-glib-1) were not met:



Título: Re: Instalar AWN-Lucido en LMDE
Publicado por: AnSnarkista en 27 de Junio de 2011, 01:46:48 pm
Osease que finalmente, mi gozo en un pozo....jajajajajajaja

gracias de todas formas, he aprendido mogollon.