torrezno

Autor Tema: Tuxguitar sin sonido en LM 12/Pulseaudio - Solución  (Leído 1673 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Louzan

  • Usuario Héroe
  • *****
  • Mensajes: 662
  • Karma: +34/-0
    • Ver Perfil
Tuxguitar sin sonido en LM 12/Pulseaudio - Solución
« en: 02 de Diciembre de 2011, 06:21:30 am »
Para solucionar este problema, que parece más por pulseaudio que por LM hay que hacer lo siguiente:

Primero instalar el paquete timidity

$ sudo aptitude install timidity

Ahora si vais en Tuxguitar a Herramientas -> Preferencias -> Sonido en la opción de Puerto MIDI ya podeis usar puertos TiMidity. Pero con esta nueva configuración al tener Tuxguitar en ejecución no tendreis sonido en las demás aplicaciones, pero hay remedio.

Ejecutais la siguiente orden:

$ timidity -iA -Os

Os devolverá algo parecido a lo siguiente:

Citar
Requested buffer size 32768, fragment size 8192
ALSA pcm 'default' set buffer size 32768, period size 8192 bytes
TiMidity starting in ALSA server mode
Opening sequencer port: 129:0 129:1 129:2 129:3

(Remarqué en negrita la parte importante)

Entonces, sin cerrar la terminal ni interrumpir este proceso, volveis a abrir Tuxguitar y en la opción Puerto MIDI mencionada antes aparecen más TiMidity ports.

En mi caso elegiría el que pone 129:0 y ya va todo bien.

Habría que tener la terminal siempre con ese proceso para que funcione bien, pero lo que podeis hacer es añadir esta orden en programas al inicio. En el caso de Gnome Shell ejecutando:

$ gnome-session-properties

Aparece el diálogo para configurar las aplicaciones al inicio. Pues le dais a Añadir y en nombre y comentario poneis lo que querais, pero en orden lo siguiente:

Citar
timidity -iA -Os

Enotnces en el próximo inicio del sistema y todos lo siguientes ya tendreis esta aplicación funcionando y manteniendo los puertos Midi que funcionan bien para aplicaciones que tiren de el, ya sabeis que el puerto 129:0, por lo menos en mi caso, está ocupado, si ejecutais otras apps que usen Midi le poneis el 129:1, 129:2 o 129:3.

Si necesitais más puertos tendreis que ejecutar una segunda vez la orden de timidity, y para que quede fijo en los inicios añadir otra orden en el diálogo de antes.

Un saludo.
« Última modificación: 04 de Diciembre de 2011, 08:15:28 am por Louzan »




Louzan

  • Usuario Héroe
  • *****
  • Mensajes: 662
  • Karma: +34/-0
    • Ver Perfil
Re: Tuxguitar sin sonido en LM 12/Pulseaudio - Solución
« Respuesta #1 en: 04 de Diciembre de 2011, 08:15:08 am »
2º Solución - Yo la recomiendo

Hay otra salida, para mi mejor aunque no lo parezca a priori. Pero por lo menos en mi caso (LM 12 con pulseaudio) va mejor.

El problema de la solución anterior es que el Tuxguitar no sigue bien el ritmo y tempo de las canciones y encontre una solución a ello, pero mientras se reproduzca en dicho programa (o se use un puerto midi con cualquier otro) no se dispondrá de sonido en las demás aplicaciones (reproductores de video/audio, navegadores web, etc), así que mientras se usa midi no reproduzcais ningún otro tipo de sonido si seguis esta opción.

Hay que descargarse el timidity al igual que antes. Pero nada de ejecutar esa orden que comenté en el post anterior, si ya teneis la orden al inicio desactivadla y editais un archivo de texto de la siguiente manera (aseguraos primero de que teneis timidity-deamon instalado):

$ sudo gedit /etc/default/timidity

Y en las lineas que pongan

Citar
# uncomment to override enabling triggered by availability of timidity-deamon
#TIM_ALSASEQ=false

# Setting overrides (of /etc/timidity.conf) for the ALSA sequencer daemon
TIM_ALSASEQPARAMS=""

Deben quedar así

Citar
# uncomment to override enabling triggered by availability of timidity-deamon
TIM_ALSASEQ=true

# Setting overrides (of /etc/timidity.conf) for the ALSA sequencer daemon
TIM_ALSASEQPARAMS="-iA -B2,8 -Os1l -s 44100"

Disculpad las molestias de no tener sonido en nada más, pero es la mejor solución que se para tener buena reproducción de midi.

Un saludo.



 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26