Autor Tema: Problema con BIOS y GRUB  (Leído 2486 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Camiloalcubo

  • Usuario Jr
  • **
  • Mensajes: 88
  • Karma: +1/-0
    • Ver Perfil
Problema con BIOS y GRUB
« en: 11 de Septiembre de 2011, 04:17:52 pm »
Hola de nuevo.
Miren, hace un tiempo he estado intentando instalar OpenSUSE. En sda1 tengo LMDE; sda2, NTFS (archivos); sda3 swap; sda4, Ubuntu.
En un principio mi disco estaba distribuido así y además, tenía 10Gb perdidos que no podía utilizar. Como no puedo crear una 5º partición primaria decidí dejar esos 10Gb allí mientras buscaba algo mejor. Ubuntu comenzó a fallar y decidí emigrar a LMDE (antes allí tenía WIn). Todo esto hace ya un año o más. Ahora que encontré OpenSUSE KDE 11.4 quisé tenerlo en mi computador. Puse el CD LiveKDE de OpenSUSE y seguí con la instalación. A pesar de que pedía español habían cosas en inglés, así es que anoté lo más posible para reiniciar y buscar en internet los procedimientos de instalación más adecuados. Desafortunadamente, me apareció un error que no supe "manejar". En inglés me decía que no tenía más de 1Gb de "no se qué" y que el espacio era insuficiente. Como no sabía de qué espacio hablaba asumí que se refería a espacio en el disco, pero como sabía que había, lo instalé igual. Ese fue mi error. Luego, seleccioné las particiones que iba a colocar. Ahora quedaba sda: 1 con LMDE; 2 NTFS; 3 con OpenSUSE; 4 swap. Cambié de orden las últimas dos y aproveché de agregar esos 10 Gb que estaba perdiendo. En rojo aparecían los cambios que se iban a realizar y las asdvertencias. y e las advertencias decía

The boat is installer on a partition that not lie entirely bellow128Gb. The system might not boot BIOS support only lba24 (result is error 18 during...)

La úlima parte no alcnacé a a notarla porque instalé antes x.x.
De mi inglés de colegio recordaba que "might" era una posibilidad remota, así es que instalé el sistema operativo aun con la advertencia.
Cuando reinicié, me decía

Grub loading, please wait
error 18

Buscando, llegué a un post de este foro en el que descrien todos los errores
http://www.linuxmint-hispano.com/foro/?/topic,415.0.html
que decía
18 : Selected cylinder exceeds maximum supported by BIOS

Este error se origina cuando una lectura intenta ir más alla del área direccionada por el BIOS. Este error se origina cuando se trata de leer bloques lineales. Este problema lo podemos encontrar en dicos (E)IDE mayores 512MB o de 8GB en máquinas antiguas.

La verdad es que no entiendo mucho qué significa.
Bueno, frente a esto, googlé cuanto pude y vi que la alternativa era actualizar la BIOS. Busqué cómo actualizarla y llegué a la págna que me pareció confiable puesta estaba muy detallada (no tengo la página). Lo eztraño era que no tenía post. Ahí debí detenrme. No usaba el método tradicional que luego encontré, que consistía en usar flashrom. Seguí sus pasos y me quedó la escoba en el computador. No podía iniciar nada porque no me dtectacba el teclado... estando puesto. Busqué uno con puerto USB y me corrió, pero ahora me dećia

Verifying DMI Pool Data
error: out of disk
grub rescue>

Así es que usé un CD antiguo de Ubuntu y recuperé el Grub. Ahora me inicia bien, pero no tengo el opensuse porque debí poner Ubuntu de nuevo (que ni si quiea terminó de instlar)

La pregunta es, alguien experto me podría decir cómo actualizar la BIOS sin que me pase lo mismo de nuevo? o sea, actualizar la BIOS y que sobreviva jajajaja..

Lo que sé de mi BIOS es que cuando le doy a cargar la BIOS dice
Phoenix - AwardBIOS CMOS Setup utility (P4M80-M7A)
Es un olidata la placa madre no srecuerdo cuál es y la BIOS está con clave que no es 0000 ni 1234 ni nada así.
Agradezco de antemano su ayuda. Si encentro algo confiable, comento.

---------------------------

P.D.: Una enla instalación de OSuse, hay una parte en la que decido los SO que quiero cargar y el orden de boteo. La primera vez no puse el LMDE porque no me di cuenta, y sólo aparecía Opensuse en el grub.. interesante porque el grub funcionaba. Cuando lo instalé de nuevo, cargué LMDE y lo dejçe en primer lugar.. aquí es cuando falló todo.

--------------------------
P.P.D.:
BIOS
Date          9/19/2005
Vendor      Phoenix Technologies, LTD (www.phoenix.com)
Version     6.00

Board:
Name        P4M800CE-8237


Visité la página de phoenix, pero todos los servicios que ofrece son para Windows. Archivos ejecutables para windows.. .exe
--------------------------
Bueno, instalé wine y corrí el programa
Me manda a la página de phoenix donde me entrega el siguiente diagnóstico:


« Última modificación: 11 de Septiembre de 2011, 05:08:40 pm por Camiloalcubo »


mint777

  • Moderador Global
  • Usuario Héroe
  • *****
  • Mensajes: 1820
  • Karma: +118/-1
  • Only 64 bits user
    • Ver Perfil
Re: Problema con BIOS y GRUB
« Respuesta #1 en: 12 de Septiembre de 2011, 07:36:01 am »
Citar
Bueno, instalé wine y corrí el programa

Esto no es recomendable, el sistema emulado arroja datos erroneos de hardware.

Segun la informacion que posteas:

Citar
Name        P4M800CE-8237

Todo parece indicar que tu tarjeta madre es esta Biostar:

VIA P4M800 / VT8237             ---->  http://www.biostar.com.tw/app/en/mb/content.php?S_ID=92

Si es asi, temo darte la mala noticia de que solo bajo windows es soportada la actualizacion del bios.

Si la ley en tu pais lo permite, mi recomendacion es que actualizes desde winxp portable (usb) ------> http://www.illasaron.com/html/modules.php?name=News&file=article&sid=1885
Si no funciona, entonces hazlo desde un xp live-cd -------> http://www.taringa.net/posts/downloads/1204499/_Recomendado_-Windows-Xp-Professional-Live-CD-v2.html
Si no funciona, entonces actualiza desde un xp light --->  http://www.taringa.net/posts/downloads/8250511/Windows-XP-SP3-Speed-Light-_Version-Lite_.html

Fuera de la Net por causas de fuer$a mayor.....come back later.

Camiloalcubo

  • Usuario Jr
  • **
  • Mensajes: 88
  • Karma: +1/-0
    • Ver Perfil
Re: Problema con BIOS y GRUB
« Respuesta #2 en: 12 de Septiembre de 2011, 06:48:16 pm »
Es la tercera vez que intento escrbir este mensaje jojojo..
mint777, primero muchas gracias (¿eres mint77?).
te cuento que ya estoy en windows. Antes de que me recomendaras estarlo lo estaba instalando. Entré a la página y efectivamente la información es completta ahora. He intentado colcarte las imágenes pero  no puedo. Mira, con cosas de configuración me atrevo (y me he atrevido) a probar de todo.. experimentar y googlear semanas enteras (ya son testigos), sin embargo, tratándose de la BIOS prefiero acuidr a este foro, que es el único que me da confianza. No quiero dejar mi sistema inutlilizable, como casi lo dejo ayer por tocar "un"archivo. Necesito sser cuidadoso con esto porque sé que es delicado. Ahora, el problema es que en la página hay que pagar para actualziar.. más encima, por cada driver.. eso no puede ser.
Cómo puedo actualizarla con la información que me dan? o bien, la solución al problema principal: Instalar LMDE (Que windows destruyó :p) y OpenSUSE KDE 11.4 con mi BIOS antigua?.
-----------------------
P.D.: En esta página
http://www.biostar.com.tw/app/en/mb/bios.php?S_ID=92
puedo descargar un zip (en la página que me dejó la escoba se hablaba de un zip). Servirá?
Además hay un .bsa que al cliquearlo me dice
If your motherboard support BIO-UNLOCKING function, please try to load BIOS optimized default before update BIOS.
lo ejecuto? Mi Bios tiene clave y nunca he sabido cual es.. no es 000 1234 etc.. será peligroso?
« Última modificación: 12 de Septiembre de 2011, 07:07:22 pm por Camiloalcubo »


Camiloalcubo

  • Usuario Jr
  • **
  • Mensajes: 88
  • Karma: +1/-0
    • Ver Perfil
Re: Problema con BIOS y GRUB
« Respuesta #3 en: 12 de Septiembre de 2011, 06:52:41 pm »
Capturas

Camiloalcubo

  • Usuario Jr
  • **
  • Mensajes: 88
  • Karma: +1/-0
    • Ver Perfil
Re: Problema con BIOS y GRUB
« Respuesta #4 en: 13 de Septiembre de 2011, 01:22:13 pm »
Bueno, he logrado instalar OpenSUSE sin que me aparezca ese error pero ha surgido un error nuevo que se sale de este tema, así es que crearé un tema nuevo.
Para que no arrojara el error, instalé  OpenSUSE en la primera partición. Es lo único diferente que hecho, no sé si efectivamente es eso o no, pero ha funcionado :D

mint777

  • Moderador Global
  • Usuario Héroe
  • *****
  • Mensajes: 1820
  • Karma: +118/-1
  • Only 64 bits user
    • Ver Perfil
Re: Problema con BIOS y GRUB
« Respuesta #5 en: 14 de Septiembre de 2011, 12:01:41 pm »
Me alegro que lo hayas logrado y con respecto al bios, si no sabes la clave mejor ni lo actualizes.
Fuera de la Net por causas de fuer$a mayor.....come back later.

Camiloalcubo

  • Usuario Jr
  • **
  • Mensajes: 88
  • Karma: +1/-0
    • Ver Perfil
Re: Problema con BIOS y GRUB
« Respuesta #6 en: 14 de Septiembre de 2011, 01:27:00 pm »
¡Gracias mint777! :D


 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26