torrezno

Autor Tema: ocultar el menu grub en ubuntu  (Leído 5089 veces)

0 Usuarios y 1 Visitante están viendo este tema.

silen

  • Usuario Jr
  • **
  • Mensajes: 60
  • Karma: +0/-0
    • Ver Perfil
ocultar el menu grub en ubuntu
« en: 30 de Enero de 2010, 03:01:04 pm »
Hola :

me he instalado ubuntu 9.10 karmic y tengo este problema.

He actualizado el kernel desde synaptic .Yo tenia 2.6.31-14 y ahora tengo el 2.6.31-17 .La question es que ahora cada vez que inicio el pc me sale la lista del grub con el 2.6.31-17 para que elija y pulse intro  para arrancar (sino, no arranca se queda ahi ). Yo solo tengo ubuntu en el pc  .Antes de actualizar iniciaba automaticamente y no me salia ninguna pantalla de grup , sino la negra con el simbolo de ubuntu , ahora esa pantalla sale despues de eligir el kernel y darle a intro .

Mirando un poco por la web he encontrado este comando sudo gedit /boot/grub/menu.lst al ponerlo me sale el archivo menu.lst en blanco ( es malo, no ) y no esta #hiddenmenu

Como puedo volver a arrancar normalmente ?

Gracias
Saludos


_hatteras

  • Visitante
Re: ocultar el menu grub en ubuntu
« Respuesta #1 en: 31 de Enero de 2010, 11:55:23 pm »
El problema esta en que la distro que tienes ya no usa el grub sino que ahora usa el grub2.
Por eso te sale el archivo menu.list vacio, y no te funciona lo de poner hiddenmenu. La mayoríaa de información que hay en Google e internet en general es sobre el grub, no sobre el grub2 del que hay menos información ya que es mas reciente.

Leete http://www.linuxmint-hispano.com/foro/?/topic,4738.0.html sobre la edición de grub2.

( Yo sigo usando el grub que tenia en Mint 7 porque me actualice a Mint 8 a traves de internet y se me conservó , pero si instalas Mint 8 desde cero se instala el grub2 en vez del grub )

silen

  • Usuario Jr
  • **
  • Mensajes: 60
  • Karma: +0/-0
    • Ver Perfil
Re: ocultar el menu grub en ubuntu
« Respuesta #2 en: 01 de Febrero de 2010, 06:45:44 am »
Hola Hatteras,

Por lo poco que se el grub2 esta bien .Este es el fichero

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT="10"
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entrys
#GRUB_DISABLE_LINUX_RECOVERY="true"

Pero no consigo que no salga el menu


_hatteras

  • Visitante
Re: ocultar el menu grub en ubuntu
« Respuesta #3 en: 01 de Febrero de 2010, 08:11:17 am »
Creo que en la sección "Cambiar el tiempo de espera y sistema operativo por defecto" de http://www.guia-ubuntu.org/index.php?title=Grub#Grub_2  explican como hacerlo:

 Cambiar el tiempo de espera y sistema operativo por defecto

Estos parámetros se modifican en el archivo /etc/default/grub:

$ sudo gedit /etc/default/grub

En la sección:

GRUB_DEFAULT=0   

Sistema operativo por defecto, 0 es el primero, 1 el segundo, etc.

GRUB_TIMEOUT="10"   

Tiempo de espera en segundos Despues de modificar el archivo, debemos actualizar grub.cfg con el comando:

sudo update-grub2
-----------------

Suerte

silen

  • Usuario Jr
  • **
  • Mensajes: 60
  • Karma: +0/-0
    • Ver Perfil
Re: ocultar el menu grub en ubuntu
« Respuesta #4 en: 01 de Febrero de 2010, 08:24:34 am »
Hola parece que lo he solucionado, tenia puesto el booteo concurrente lo he desactivado, y ya no me sale el menu .

Gracias Hatteras.

 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26